fb logo  VK  Feed icon.svg  

Проброс порта на MikroTik для одного и двух провайдеров

опубликовал от 02 Август, 2016

Сколько было написано инструкций по настройке, а такой простой вещи как проброс порта в MikroTik на нашем сайте не было. Исправил этот недочёт. Рассмотрим сегодня несколько способов публикации вашего сервера в сети интернет на маршрутизаторах MikroTik. Также раскажу про публикацию сервера на двух внешних IP адресах. Есть очень простой способ это сделать не прибегая к маркировке исходящих и входящий соединений.

Для тех кто не хочет тратить своё дорогое время на изучение данного мануала предлагаем нашу платную помощь.

1. Простой проброс порта если нет статического IP

В самом простом случае проброс порта привязывется к внешнуму интерфейсу In. Interface. Для этого идём в IP/Firewall на вкладку NAT и плюсиком создаём правило:

 

 Цепочка dst-nat, входящий интерфейс ByFly, порт TCP 55555

Если порт на входе равен порту на выходе или пробросить нужно несколько портов одним правилом в поле "To port" можно ничего не писать:

 Из командной строки надо исполнить такой скрипт:

/ip firewall nat
add action=dst-nat chain=dstnat comment=torrent dst-port=55555 in-interface=\
ByFly protocol=tcp to-addresses=10.24.3.2

2. Проброс группы портов если есть статический IP

Этот же способ называется Hairpin Nat на MikroTik.

Если у провайдера выкуплен внешний статический IP правило лучше видоизменить:

Это позволит открывать изнутри сети ресурсы сервера по внешнему IP. Очень полезно для настройки на переносных устройствах которые могут подключаться к серверу как из других сетей так и по Wi-Fi. В данном случае рассмотрен проброс нескольких портов одним правилом: TCP 55555, 80, 21. 86.57.150.15 - внешний IP.

Из коммандной строки следует выполнить:

/ip firewall nat
add action=dst-nat chain=dstnat comment=probros_web_ftp_torrent dst-address=86.57.150.15\
dst-port=55555,21,80 protocol=tcp to-addresses=10.24.3.2

 3. Публикация сервера на 2-ух внешних IP

Для начала следует прописать на сервере второй IP адресс из другой подсети на сетевом интерфейсе:

 Добавляем столько адресов сколько нам нужно:

Идём в IP adresses и добавляем на сетевом интерфейсе ip 10.24.4.1/24 через который будет идти взаимодействие маршрутизатора с сервером:

Сделаем маршрут для второго провайдера с меткой route-1 для этого идём в IP/Route:

Создадим правило согласно которому сеть 10.24.4.0/24 роутится через второго провайдера:

К основному пробросу портов надо добавить проброс порта через второго провайдера:

где 86.57.150.16 IP второго провайдера.

Соответственно пробрасываем на IP 10.24.4.2:

Необходимо сделать также masquerade при обращении к 10.24.4.2 для того чтобы подключение ко второму IP WINDOWS работало:

 Настройка закончена! Теперь сервер доступен c двух внешних IP.

Прочитано 51689 раз Последнее изменение Четверг, 28 Июль 2022 14:15
Кардаш Александр

Автор статей по настройке ОС и сетевого оборудования. Отвечу на форуме на ваши вопросы. Добрый айтишник! 

Сайт: https://netflow.by/forum/newtopic

Другие материалы с нашего сайта:

Комментарии   

Vladimir
# +1 Vladimir 18.02.2022 21:01
Написано слишком кратко и фрагментарно для начинающих, а разобравшимся это уже не нужно. Например что за адрес 10.24.4.2, откуда он взялся, для чего нужен? Зачем мне тратить время на понимание этого, если мне интересно пробросить порты?)))
Ответить
Алекс Ньюсмейкер
# -2 Алекс Ньюсмейкер 19.02.2022 13:16
Статья разделена на три части: 1 - для начинающих, 2 - для разобравшихся и желающих что-то улучшить, 3 - для профессионалов решающих сложные задачи..... По поводу адреса 10.24.4.2 можете не разбираться - это относится к очень специфической задаче профессионалов....
Ответить
Kasheftin
# 0 Kasheftin 15.02.2021 19:02
Добрый день.
Поставил дома мини-сервер, настроил проброс портов для статического IP. Работает.
Вот только не работает для других компьютеров из той же локальной сети - для них открывается админка роутера. Видимо, дело в том, что правило прописано для dst-nat, а нужно еще какое-то правило для src-nat?

Ответ: Наверное админку с 80 порта надо перенести на другой....
Ответить
Игорь
# 0 Игорь 19.12.2017 13:20
Добрый день!
подскажите пожалуйста есть роутер Mikrotik RB 951 2n, задача состоит в том чтобы настроить 3 и 4 порт на двух независимых провайдеров, оба провайдера заходят на микротик 1 и 2 порт по DHCP, 1 провайдер шлюз 192.168.1.1 второй 192.168.100.1 как настроить так, чтобы VLAN с сетью 172.200.2.0/24 (3порт) работал через провайдера со шлюзом 192.168.1.1, а VLAN с сетью 172.200.10.0/24 (4порт) работал через провайдера со шлюзом 192.168.100.1 и вообще возможно такое сделать на данной модели. Заранее спасибо!!!

Ответ: Конечно возможно. Роутинг полиси так называемый надо использовать...
Ответить
Vlad
# 0 Vlad 05.07.2017 00:44
Добрый день!

Адрес 192.168.8.1 - ето адрес чего у Вас?
Там где Сделаем маршрут для второго провайдера с меткой ....

Ответ: Это адрес шлюза второго провайдера ....
Ответить

Добавить комментарий

Комментарий будет удалён, если не будет содержать осмысленный текст. В тексте сообщения не должно быть бесполезных ссылок на другие сайты.

 rss  vk groupe

 

Женщины, как web-сервер
Женщины, как web-сервер 400 Ваd Rеquеst — свидание без букета.401 Unаuthоrizеd — замужем.402 Рауmеnt Rеquirеd — ужин при свечах.403 Fоrbiddеn — я знать тебя больше не хочу!404 Nоt Fоund — сегодня я гуляю с подругами.405 Меthоd Nоt Аllоwеd — нет, только не сзади….407 Рrоху Аuth. Rеquirеd — мне
Компьютеризмы
И сисадмины скачивают порнуху. Каждая мышка должна знать свой коврик. Если Windows больше нечего сказать, он посылает всех на три клавиши. И лицензионный Windows глючит. Троянский конь всегда найдет ахиллесову пяту вашего компьютера. Хороший сисадмин никогда не перепутает дисковый Raid от Raid
Шаманхуев
Однажды молодой сисадмин познакомился с веб-дизайнершей. По привычке он сразу же спросил, какой у нее iр-адрес, но услышав, что IP-адрес у нее динамический, тут же потерял к ней всякий интерес.
«
»
  • 1
  • 2
  • 3
  • 4
  • 5

Нравится ли вам наш блог?

Услуги по удалённой настройке MikroTik от профессионала
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги переустановки Windows с выездом в офис
Переустановка Windows на дому и офисе с выездом по Минску весьма востребованная услуга. Иногда ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных
Услуги ремонта компьютеров с выездом в офис
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же сбоя в программном обеспечении. Зачастую, это происходит в самый неподходящий момент: когда нужно
Услуги настройки Wi-Fi сети на дому и в офисе
Настроим любые Wi-Fi роутеры с выездом к вам на дом или в офис по Минску. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и
Услуги по настройке модемов на дому и в офисе
Настроим роутеры белорусских интернет провайдеров с выездом на дом и в офис по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако
Услуги установки и настройки свободных программ
Для начинающих пользователей Windows и Mac мы предлагаем услуги установки и настройки свободного программного обеспечения с выездом по Минску в офис. Предлагаем вам установить: пакет офисных
Услуги настройки роутеров в офисе и на дому
Использование маршрутизатора (англ. router) возможно только после его правильной настройки, а это не так уж и просто. Как правило нет опредёлённой методологии для осуществления настройки, ведь
Услуги настройки и обслуживания локальных сетей
Настройка локальной сети в Минске является ответственным этапом запуска сетей и требует тщательной проработки квалифицированными специалистами. Локальные сети (проводные и беспроводные) дают
Услуги монтажа локальной вычислительной сети
Прокладка локальных сетей это комплексная работа, которая выполняется нашими специалистами качественно, продуманно и в сроки, четко оговоренные с заказчиком. На сегодняшний день, прокладка
Услуги подключения и настройки периферийных устройств
Если Вы приобрели оборудование для персонального компьютера, но не знаете как его установить и настроить, не хотите копаться в тонкостях подобных работ или же не имеете на это время, опытные
Услуги чистки ноутбуков от пыли в офисе
Одна из самых распространенных неисправностей ноутбука является перегрев из-за забившейся пылью системы охлаждения. В следствии чего ноутбук тормозит, а порой даже выключается.  Если Ваш

Авторизация